What are the minimum system requirements for your iOS & Android applications?

Our iOS App requires a minimum of version iOS 10 installed, and our Android app requires the minimum version of Android 5.0.
For MUBI GO, the minimum supported version on iOS is 11.3.

Still need help? Contact Us Contact Us